Changes to Quoll Writer

Version 2.6.14, released: 17/Jul/2018

Bug fixes

  • An issue preventing custom objects, due to orphan data, from being deleted has been fixed.

Version 2.6.13, released: 02/Jul/2018

Minor changes

  • When entering full screen mode the original project window will now be hidden. This should prevent issues with focus traversal and the original project window being given focus when the full screen window loses focus.
  • Less information is now sent back to the Quoll Writer server when an error is automatically reported or when a user submits a bug report.

Version 2.6.12, released: 22/Jun/2018

Bug fixes

  • Fixed the EPUB export so that it uses UTF-8 in all cases.
  • Added a language code to the DOCX and EPUB exports based on the current spellcheck language for the project.

Version 2.6.11, released: 04/Jun/2018

Bug fixes

  • Fixed an issue with asset names not being displayed correctly.
  • Fixed an issue where the custom object field ordering could become incorrect when the user dragged/dropped the fields.

Version 2.6.10, released: 31/May/2018

Bug fixes

  • A number of fixes relating to the User Interface strings editor.

Version 2.6.9, released: 20/Apr/2018

Bug fixes

  • Brought the built-in User Interface strings version up to date with the Quoll Writer version. This was preventing certain functionality within the Strings Editor from working correctly.

Version 2.6.8, released: 18/Apr/2018

Bug fixes

  • Fixed an issue that caused the text boxes to resize inappropriately when text is entered/removed.

Version 2.6.7, released: 17/Mar/2018

Bug fixes

  • Fixed an issue that caused the add/edit Idea box to resize when the text was overflowing the box size.

Version 2.6.6, released: 03/Mar/2018

Bug fixes

  • Fixed an issue with missing images preventing custom fields/types from being edited/created.

Version 2.6.5, released: 02/Mar/2018

New feature - Support for creation of User Interface translations

It is now possible to create new language User Interface translations. A Language Strings Editor has been created to enable easy creation and management of translations. See: the overview for full details.

Version 2.6.4, released: 18/Oct/2017

Bug fixes

  • Fixed an issue preventing a project from being opened when asset types are removed, specifically the legacy or built-in types.

Version 2.6.2, released: 28/May/2017

Bug fixes

  • Fixed an issue preventing a project from being opened when tags or assets are removed.

Version 2.6.1, released: 26/May/2017

Bug fixes

  • Fixed an issue preventing a project from being removed when there is no files directory.
  • Fixed an issue with the select form item throwing an error when there are no items.

Version 2.6, released: 12/May/2017

New feature - Configurable Assets

Characters, Locations, Research Items and Items can now have extra configurable fields added to them.

New types of Asset can now be created. Click here for more information.

New feature - Object tagging

Objects can now be tagged and grouped into their own sections within the sidebar. Click here for more information.

New feature - Section hiding

Sections in the sidebar can now be hidden or shown as needed.

New feature - Section drag-n-drop

Sections in the sidebar can be moved up or down via drag-n-drop.

New feature - Object sorting

Objects within a section (except for Scenes, Outline items and Notes) can be ordered via drag-n-drop. Assets can be sorted via the data in the fields they contain, if the field can be sorted.

Minor changes

  • Forms now use a stacked layout instead of columns. The way that forms are generated has been overhauled.
  • A new Assets & Tags section has been added to the Options panel.
  • Existing asset types, Characters, Locations, Research Items and Items have been made configurable and are considered legacy types.
  • A screenshot of the current window can now be sent with a bug report.
  • Form popups (such as adding a new scene or outline item) can no longer be removed using the Escape key (it was causing icons to be left behind and needs substantial work to support the proper use of the Escape key in this case).
  • Merging of assets when importing from another project or file is no longer supported, this is due to assets now being user configurable and the uncertainty of what to do when there are data type/field mismatches. A future version may return this feature.

Bug fixes

  • Fixed an NPE that can occur when the user is opening an encrypted project and the auto-login for the Editors service is trying to display a notification in the current viewer.
  • Editor projects no longer count towards word counts for the session.
  • Deleting an editor project from the projects window will now send a message back to the author that you are no longer editing the project.
  • Fixed an issue where too much text was being used as the summary of a scene or outline item.

Version 2.5.9, released: 27/Nov/2016

New feature - Editing assets has changed... again

After some very useful feedback, the way that assets (such as characters and locations) has been changed... again. But this time to add more options and flexibility. You can now choose whether you want to edit assets within a popup or within their own tab. If you choose editing within the tab then the Appears in Chapters section will disappear while you edit, giving you more space.

Bug fixes

  • Fixed an issue relating to how A4 page counts were being performed.

Version 2.5.6, released: 13/Nov/2016

New feature - New way to interact with the Problem Finder

You can now find all problems of a particular type across all chapters. The results are shown in a side bar. Just right click on a problem found or use the new button in the Problem Finder config window. Additionally, a new rule has been added to find duplicate words and/or punctuation.

New feature - Editing assets has changed

The way that assets (such as characters and locations) has been changed. Instead of editing them within the tab, they are now edited via a popup, in the same way they are added. I understand this may be a change that is NOT to everyone's liking, if this is the case then please contact me to let me know you're not happy. This change was made primarily for technical reasons not user interface ones and as such I'm not committed to it but I think overall it is better this way, although I think the description area needs to be increased in size. Either way, if you want it to be changed back, don't hesitate to let me know.

Minor changes

  • The version of docx4j has been updated, hopefully this brings performance and compatibility improvements for importing/exporting docx files.
  • Added a Find your Projects right click menu item to the projects window.
  • Added a right click menu for assets.
  • You can now mark a comment received from an editor as "Dealt with" to help with tracking and management of comments.

Bug fixes

  • Fixed an issue preventing the synonym lookup menu item from being displayed.
  • Fixed an issue with styled text not having the correct amount of whitespace around it when exported to docx format.
  • Project exports now use the correct property set so the font, font size etc should be correct in the exported document.
  • Edit complete markers are no longer shown in the chapter list or icon column for an editor project.
  • Only a single item can be displayed (the popup) in the editor chapter panel.
  • The way that background tasks are handled has been changed, hopefully this should prevent some of the stranger errors I was receiving.
  • Fixed an issue that prevented upgrading to new versions under certain circumstances.

Version 2.5.5, released: 12/Nov/2016

New feature - New way to interact with the Problem Finder

You can now find all problems of a particular type across all chapters. The results are shown in a side bar. Just right click on a problem found or use the new button in the Problem Finder config window. Additionally, a new rule has been added to find duplicate words and/or punctuation.

New feature - Editing assets has changed

The way that assets (such as characters and locations) has been changed. Instead of editing them within the tab, they are now edited via a popup, in the same way they are added. I understand this may be a change that is NOT to everyone's liking, if this is the case then please contact me to let me know you're not happy. This change was made primarily for technical reasons not user interface ones and as such I'm not committed to it but I think overall it is better this way, although I think the description area needs to be increased in size. Either way, if you want it to be changed back, don't hesitate to let me know.

Minor changes

  • The version of docx4j has been updated, hopefully this brings performance and compatibility improvements for importing/exporting docx files.
  • Added a Find your Projects right click menu item to the projects window.
  • Added a right click menu for assets.
  • You can now mark a comment received from an editor as "Dealt with" to help with tracking and management of comments.

Bug fixes

  • Fixed an issue preventing the synonym lookup menu item from being displayed.
  • Fixed an issue with styled text not having the correct amount of whitespace around it when exported to docx format.
  • Project exports now use the correct property set so the font, font size etc should be correct in the exported document.
  • Edit complete markers are no longer shown in the chapter list or icon column for an editor project.
  • Only a single item can be displayed (the popup) in the editor chapter panel.
  • The way that background tasks are handled has been changed, hopefully this should prevent some of the stranger errors I was receiving.

Version 2.5.3, released: 16/Aug/2016

Minor changes

  • The way that upgrades are handled has been changed, very little has changed from an end user perspective but it should bring a number of benefits at the cost of a larger file size. See: this blog post for more details.

Bug fixes

  • A number of fixes have been made to the Import File/Project wizard.

Version 2.5.2, released: 04/Aug/2016

New feature - Improved, configurable chapter previews

The information displayed in the popup when you hover the mouse over a chapter in the chapter list can now be configured. See: this page for details on how to configure what is displayed.

New feature - Import from another project

It is now possible to import characters, chapters, locations and so on from another project.

Minor changes

  • If the find sidebar is already open then hitting Ctrl+F will give focus to the find field.

Bug fixes

  • Prevented a white line from showing up in distraction free mode when using a dark theme.

Version 2.5.1, released: 07/Jul/2016

Bug fixes

  • Fixed an issue that prevented the application from exiting when a new user creates their first project.
  • Fixed an issue that prevented the Editors environment from being initialized.

Version 2.5, released: 06/Jul/2016

New feature - Targets

You can now set certain targets to track how your writing is progressing. Set targets for how much you write in a session, every day, week or month. A number of new charts have been added to help you track these statistics over time. You can also specify targets for chapter length and readability.

New feature - New Charts & a Chart revamp

The following new charts have been added:

  • Display current word counts for all chapters, this has integration with the chapter word count target.
  • Display current readability indices for all chapters, this has integration with the readability targets.
  • Display session word count, again this has integration with the session word count target.
  • Display session length.

New feature - The writing area background and text color can be changed in normal mode

I think it makes things look hideous but enough people have asked for it!

New feature - Option to always display the current time/word count in full screen mode

A new setting in the full screen properties will allow you to always have the current time and word count (including targets) display in full screen mode.

Minor changes

  • The Beta tag has been removed from the Editors Mode service.
  • The For time duration values in the charts have been changed to be more useful.
  • Invites to pending contacts can now be resent.
  • The default new project directory is now derived from the last opened normal project not the last project.
  • The icon column color is no longer updated when the background color of the writing area is changed.
  • The version selector for switching between versions of a project received now shows the number of comments each version has.
  • Sent/Received has been added to the comments box title to indicate the direction of the comments.
  • Drag-n-drop of a file onto an asset or chapter has been removed due to Java 8 introducing some stupid bug that I can't fix. I hope to re-add the feature in a future version... grr...
  • Documents opened from the asset document panel will open as a file rather than a url.
  • When creating a new chapter from an idea use the idea text as the chapter description.
  • A number of performance enhancements have been introduced, not least chapter word counts are now calculated in the background and trigger on text changes rather than at regular intervals.
  • New keyboard shortcut - Ctrl+Shift+H to add a new chapter at any time.
  • New toolbar and chapter right click menu items for adding a new chapter.
  • When importing a file, any assets that already exist in the project will merge with assets being imported with the same name/type.
  • The current Java version is now displayed in the About Quoll Writer popup.
  • A couple of new achievements related to backups have been added.
  • New keyboard shortcut - Ctrl+N to add a new project at any time.
  • New keyboard shortcut - Ctrl+O to open a project at any time.
  • When there are no backups for the project the backups popup will display a message indicating this.
  • Links to assets in description now works on the name of the asset rather than it's id/key. If multiple assets match the name (through aliases or partial matches) then a popup will be displayed asking which one the user wishes to view.
  • The color selector has been reworked to support direct entry of a HEX code and RGB selection through a slider. Previously selected colors are displayed below for easy access.
  • Text pasted into a chapter will have control characters removed and smart quotes replaced with normal quotes.

Bug fixes

  • Empty chapters can now be sent to an Editor.
  • Only a single viewer is shown for any comments sent about a project.
  • The Editor Mode service Logging in... popup will now disappear is there is an issue with logging into the service.
  • A number of tips have been brought up to date and tweaked to ensure they display the correct panel/sidebar/feature when the associated link is clicked.
  • Items in the find will now be unselected when a different item is selected.
  • The split chapter option is now only available when the caret is not at the end of the text.
  • When a chapter is deleted any associated sidebars, such as chapter information, are also removed.
  • Only show the link to view the backups directory when the directory exists.
  • Ensure that the chapter information sidebar can be shown when there is no associated chapter tab.
  • Fixed an issue where, if part of an asset's name was the same as another asset, then the links in descriptions would mess up.
  • The problem file properties.xml is no longer used and user properties are now saved to the projects database. This file would (rarely) become corrupted for some reason I could never divine causing QW to not start. This sidesteps the problem and has the advantage of making things more portable.
  • Selected chapters and assets can now be exported to the EPUB format.
  • When sending an invite to an Editor the Editor is now added to your local Editor database prior to the invite being sent.

Version 2.4.2, released: 23/Jan/2016

Minor changes

  • Invites to pending contacts can now be resent.

Bug fixes

  • The onShow event now fires when a sidebar is shown in full screen.
  • A number of minor changes to prevent null pointer exceptions when expected objects are not present.
  • The correct insets are now used when calculating the location of a popup.
  • Tweak to sorting when two objects have the same name.
  • The "Report a Bug" popup is now displayed when the user decides to contact support about a problem rather than directing them to the QW website.
  • The character < is now checked as the terminator of a url as well as whitespace.

Version 2.4.1, released: 23/Oct/2015

Bug fixes

  • Fixed the words in chapters being split in strange ways when resizing the window or moving in and out of full screen mode.
  • Fixed an issue where some projects and the Editors database couldn't be opened.
  • Added in missing icons used in the Projects Window.
  • If the Projects window is open but not visible, opening a project will now bring it to the front.
  • A couple of internal errors have been corrected.

Version 2.4, released: 18/Oct/2015

New feature - Projects Window

The Projects window is a new way to interact with and manage your projects. Each project is listed with configurable details about the number of chapters it contains, how many words and its status.

New feature - Asset Documents

It is now possible to add documents to Characters, Items, Locations and Research. The documents are basically links to files on your hard drive rather than the files being stored in your project. Drag-n-drop a file onto an asset tab to quickly add the document.

New feature - Drag-n-drop import

Support for importing .docx files via drag-n-drop has been added, when viewing a chapter tab just drag-n-drop the file onto the project to begin the import.

New feature - New first use wizard

A new wizard has been added for new users to get them up and running quickly.

New feature - Backups

It is now possible to manage backups of your project (previously called Snapshots), you can specify where they are stored, how many to keep and restore your project to a previous point in time.

New feature - Bold/italic/underline

Support for bold/italic/underline has been added just about anywhere you see a multi-line text box. Spellchecker support and synonym lookups are also supported.

New feature - Close a tab via middle click

It is now possible to close a tab via a middle click or via a right click and selecting "Close" from the menu.

New feature - Projects database

The old projects.xml file has been retired in favor of a new projects database which stores information about your projects.

Minor changes

  • The h2 jar file has been updated to the latest stable version.
  • Spell check of a word only occurs when the caret has left the word.
  • Improved typewriter sound so it only triggers when the chapter text actually changes (so won't play when you press Ctrl or a keyboard shortcut).
  • Removed use of BreakIterator in favor of TextIterator to improve text splitting and measurement.

Bug fixes

  • If there is no avatar for user then "Me" will now display instead of throwing an error.
  • Fixed an issue where, if you delete a chapter with unsaved changes and auto save is enabled then an internal error is thrown (the user never sees it).
  • Fixed an issue with invalid characters in chapter text preventing a save.
  • "Click to try out the typewriter sound" link in the tip now works.
  • Spellchecker now highlights the correct text when there are leading white space characters at the start of a line.
  • Fixed broken word wrapping when moving from normal mode to full screen mode.

Version 2.3.1, released: 05/Aug/2015

Bug fixes

  • Fixed an issue when you first create a project and link objects together. This fix should also fix a number of other db related issues that only occur when you first create a project.
  • Fixed an issue where, having set a background image for the idea board if you then remove the image it prevents QW from loading the idea board.
  • Fixed an issue with the link to tree so that it resizes the associated popup when you expand/collapse a tree node.
  • Fixed an issue where, if you delete a chapter and it's associated information sidebar is visible then an error is thrown.
  • Fixed the font sizes of the field labels when you edit an asset.
  • Top-aligned the "Description" field when adding notes/plot outline items/scenes and assets (characters etc).

Version 2.3, released: 04/Aug/2015

New feature - Editor Mode beta

Editor Mode, along with its companion Editors Service is now available in beta form. Everything works (as far as I can determine) however there are a few things that are still rough around the edges and may need tuning, including the backend server that provides the secure messaging facilities.

For more details on Editor Mode, click here.

New feature - Double sidebars and flexible layouts

This feature allows you to have two sidebars visible at once, say your Contacts sidebar and the Project sidebar. You can also select where each sidebar is in relation to the tabbed pane.

New feature - Spellchecker change and new languages

A new spellchecker has been introduced that supports a far broader range of languages, including German, Spanish and Polish (grr, why you have to many words Polish!!!).

Feature change - removal of English dialects for the spellchecker

A side-effect of the spellchecker change is the removal of English dialects for the spellchecker. It is not currently supported, I understand this may upset some users who rely on this feature and I am looking to re-add support for the dialects in the next release.

Minor changes

  • This version requires at least Java 7.
  • A number of windows have been converted to internal popups, meaning they don't have there own OS level window and so can't get lost.
  • F7 added as a keyboard shortcut to show the Contacts sidebar.
  • Increased the scroll amount for the options panel.
  • Pressing Escape when an internal popup is visible will close it.
  • Pressing the header of an internal popup will bring to the front of all other popups.
  • Added the ability to opt-into beta versions.
  • Warm-up prompt now shown in the warm-ups sidebar rather than above the text.

Bug fixes

  • Updated snapshots so that special characters in the path don't affect it.
  • Fixed a number of issues related to changing an aspect of a chapter (for instance renaming it) when there is no associated tab for the chapter text.
  • Revamped database error handling to hopefully prevent a number of locking errors.
  • The problem finder will now iterate over all sentences and paragraphs (there were a few edge cases where it would not).
  • The problem finder will now allow ignores of multiple paragraph issues on the same paragraph.
  • Fixed a display scaling issue where text and popups would scale to the wrong size. A side-effect of this change is that QW now assumes that the user's default display pixel resolution is 96/inch which can lead to problems if it's actually different.
  • Moved the full screen frame to coordinates 0,0 to ensure it completely fills the window regardless of the position of the Windows taskbar.
  • Changed how windows are positioned so that the underlying window manager decides rather than QW centering the window.
  • Fixed description text being marked up incorrectly if you have an asset name in a url.
  • Better handling of problem finder rule edits.
  • Fixed a problem where a faulty user problem finder rule will no longer prevent other user rules from being loaded.

Version 2.2.5, released: 25/Jan/2015

Bug fixes

  • Styled text at the end of paragraphs can now be exported via the .docx exporter.

Version 2.2.4, released: 02/Aug/2014

Bug fixes

  • Keyboard shortcuts for bold, italic and underline will now toggle properly.
  • When exiting QW with unsaved changes you can choose to not save.
  • Special, OS restricted characters in a project name will no longer prevent the project from being exported.
  • All text is now exported.
  • Linking of asset names in descriptions now works on a whole word basis rather than partial text matches. In other words, Ben will no longer link to Bend.

Version 2.2.3, released: 14/Jun/2014

Bug fixes

  • Finder will show all results and scrollbars as needed.
  • Removed broken achievement: addresearchitemsocialweblink
  • Fixed exporting an empty chapter to .docx format.
  • The tabs will now save and restore in the correct order.

Version 2.2.2, released: 18/May/2014

Minor changes

  • The sidebar should now have a more consistent size.

Bug fixes

  • Fix to make the Readability Indices have sane values.
  • Fix to ensure that all the chapter information is visible.

Version 2.2.1, released: 17/May/2014

Minor changes

  • You now need to click on an idea in the Idea Board to show all the text and click the icon to close it.
  • Renaming a chapter or asset will now display a popup window asking for the name rather than editing the name in the tree..

Bug fixes

  • Middle clicking on a tab to close will no longer throw an error and prevent the tab from closing.
  • When splitting a chapter and got some text selected, if an undo is performed the text highlight is removed.
  • When an item from the appears in chapters panel/find they will now open to the correct sentence if the chapter doesn't have a tab open.
  • Multiple word searches will show in the find. Multi-word names will now show in the appears in chapters panel (and side bar).
  • Fixed an issue where the appears in chapters panel was showing no results when an asset had an alias that wasn't used within the text.

Version 2.2, released: 21/Apr/2014

New feature - Distraction free mode

This is accessed via full screen mode and once enabled will remove scrollbars, the left hand column and border from around the writing area. Also, typewriter scrolling will be used (since there are no scrollbars) and the writing line will be highlighted.

New feature - Writing line highlighting

The writing line (the line where the cursor is) can now be highlighted. Just edit the text properties to enable it, the background color can also be selected.

New feature - Find your project

Added a section to the open project window that allows you to find a project directory and add it. This is useful for people using Dropbox or other file syncing services and they don't sync their projects file (or are using different directory structures).

New feature - Sending errors back to base

An option has been added to allow errors to be emailed back to Quoll Writer support (well me) to help improve things.

New feature - Improved open project window

The open project window will now inform you if a project cannot be opened and if it is encrypted.

New feature - Dictionaries downloaded after install

To reduce the initial download size and get users up and running faster the dictionaries have been removed from the initial install file and will instead be downloaded when the user first creates a project.

New feature - File syncing support (Dropbox et al)

Due to the changeover to version 1.3 of H2, support for file syncing services should be much improved. The database now only uses a single file and thus there is less chance of a corruption occurring.

Minor changes

  • Better handling of errors when an encrypted project is opened.
  • Made the sidebars have more consistent widths.
  • Removed the nasty blocking "native" popups and replaced them with more consistent popups.
  • Changed allowable size of writing area in full screen mode to be larger.
  • When text color changes the caret color is also changed to match.
  • Added option to switch off object preview popups in project side bar. Improved timing so they not as annoying.
  • Added shortcuts Ctrl+E in asset tabs to edit the main information. Added Ctrl+L to edit the linked to list.
  • Added option in project menu to see what is in new in the current release.
  • Prevented multiple assets of the same type from having the same name in all cases.
  • Moved the underlying database H2 to version 1.3.175.
  • Removed configure button next to previous button from problem finder.
  • Made popups more consistent, buttons are now in the same place for similar popups.
  • Sidebar will no longer open on the right of the screen, it was a complete pain with multiple monitors.
  • Updated the jgoodies stuff to their latest versions.
  • You will no longer be prompted to exit the project unless there are changes to be saved.

Bug fixes

  • Quoll Writer can now be closed when there are no tabs open.
  • Fixed an issue where a search result wouldn't display if the associated tab (chapter) wasn't open.
  • When splitting a chapter and the first line of the new text is over 150 characters the line now displays correctly in the split chapter popup.
  • .docx export now handles paragraphs properly.
  • All edit complete text being counted for edited figure in "All Chapters" for word counts side bar.
  • The properties sidebar in full screen now won't disappear at odd times.

Version 2.1, released: 10/Jul/2013

This release focuses on the new features and bug fixes. Henceforth this version will be known as the version that shall not be named and I will never speak of it again.

New feature - Drag and drop of notes/scenes/plot outline items

Notes, scenes and plot outline items can now be dragged and moved within the chapter. I'm currently working on moving them between chapters, bear with me, Java's drag-n-drop support is a pain to work with.

New feature - Splitting a chapter

It is now possible to split a chapter at either an arbitrary point in the text or by selecting some of the text. Just right click on the chapter and select split chapter.

New feature - Compressing the right click chapter menu

An option has been added to allow the right click chapter menu to be compressed (visually).

New feature - Notes shown in chapter list

An option has been added to show notes for a chapter in the chapter list.

New feature - Changing names of objects

The names of objects, such as Chapter, Note, Character and so on can now be customized to your needs.

New feature - Edit position

You can now set an edit position in the text of a chapter that will then visually indicate where you are up to when editing. An icon will be displayed against the chapter in the chapter list to indicate that you partially way through editing.

New feature - Set edit complete

Additionally to the edit position marker you can mark a chapter as edit complete meaning that you have finished editing it.

New feature - New problem finder rules

There is now a rule that checks paragraph length and/or number of sentences. Also a rule for a rudimentary measure of sentence complexity (syllables vs word count) has been added.

New feature - Amount edited added to word counts sidebar

If one or more chapters has an edit position or has been marked edit complete then the word count panel will show the total amount edited. Similarly for the current chapter if either is set then the amount edited will be displayed.

New feature - Double click on chapter margin shows add menu

As above. A menu will be shown for adding a new note, scene or plot outline item.

Minor changes

  • Passive sentences problem finder rule now has an option to ignore dialogue.
  • When changing a word in the text via the spellcheck or synonym finder the formatting is now maintained.
  • Auto-save default value has been changed from 1 hour to 5 minutes.
  • New scenes/outline items/notes are added at the mouse position not the current caret when the mouse is in the chapter panel. Otherwise they are added at the caret.
  • When opening a previously edited chapter the text will scroll to the last position rather than the caret position.
  • If an idea has more than one sentence then a trailing elipsis will be shown when displaying the compressed idea.
  • When changing the font or font size or line spacing the caret will be kept in view regardless of how the text changes.
  • Some small improvements to how notes are displayed.
  • When working in full screen mode the Quoll Writer main window will show a panel indicating that QW is in full screen mode and allow you to exit from the panel.
  • Delete has been removed from the right click chapter menu, it was confusing and archaic, seriously does anyone ever use that?
  • Add and help buttons have been added back into the Idea Board header.
  • If a plot outline item is associated with a scene, when you view the item there will be a link to the parent scene displayed.

Bug fixes

  • Notes are now properly removed from the note tree under all circumstances.
  • Fixed an issue where edit needed notes were losing the text selection.
  • All note text is now displayed not just the first line.
  • When there are multiple scenes/plot outline items on the same "line" in the text then clicking on the icon will display them all.
  • If you have multiple monitors and QW is open on monitor 2 then you can now close QW.
  • In full screen mode if the side bar is open on the right hand side of the window then it can now be expanded via dragging.
  • Ensured that full screen text properties are saved to the correct place and not overriding user settings.
  • When deleting notes/scenes/plot outline items in full screen mode the main QW window is no longer displayed.
  • Scenes are now added into the chapter list in the proper order.

Version 2.0.1, released: 11/Mar/2013

New feature

Added a word count difference indicator to the sparklines.

Mouse over items in project sidebar

When you hover the mouse over an item in the project sidebar a popup will be displayed showing the first line of the description.

Minor changes

  • Couple of alignment tweaks to the word counts sidebar.

Bug fixes

  • Chapter information sidebar now displays sections and resizes correctly.
  • When doing a search and a new chapter is shown the relevant text is jumped to.

Version 2.0, released: 22/Feb/2013

New Feature: A new look

The look of Quoll Writer has been overhauled and now uses a monochrome look.

New Feature: A greater focus on the sidebar

Where possible the popup windows have been reduced and instead the sidebar is used instead. For example, word counts and readability indices are now displayed in the sidebar rather than in separate popups.

New Feature: Everything works in full screen mode

Full screen mode for previous versions have been limited to editing chapters only. This version allows you to work fully in full screen mode if you desire.

New Feature: Sidebar appears in full screen mode

To allow for full control in full screen mode the sidebar is now displayed in full screen mode. Just move the mouse to the left or right of the screen to make it appear.

New Feature: Icons moved and added

More icons have been added to the header bar to allow quick access to the Idea Board, the find and full screen mode.

New Feature: Chapter information is now in the sidebar

Instead of having the chapter information in a separate tab it now appears in the sidebar.

New Feature: Plan for a chapter

You can now add a plan for a chapter. Currently this is fairly rudimentary but will be improved in a future version.

New Feature: More flexible UI

You can now move the location of the sidebar and the tabs.

New Feature: Improved project sidebar

The "Assets" section has been removed and replaced with separate sections for Characters, Locations, Items and Research. A count of how many items is displayed for each section. You can still open and close the section with a mouse click. The item selected in the sidebar also reflects the current tab.

New Feature: Options has it's own tab

The popup window has been removed and the options are now in their own tab.

New Feature: Pop out "Appears in Chapters"

The Appears in Chapters section for a Character etc can now be popped out into the sidebar.

Improved Feature: Improved word counts and readability indices

Everything is shown in one place and provides more detail, such as what % of the total is the current chapter. Can also see the readability for a selected piece of text (must be more than 100 words selected).

Minor changes

  • Bigger icons are used in the tab toolbar.
  • The achievements tab has been cleaned up and is now neater.
  • No need to save options, they are saved automatically. Also some options have been made the default for projects.
  • Problem finder config has been tweaked to be more usable. Note: in a future release this will be placed into the sidebar.

Bug fixes

  • Lots, however due to the vast changes introduced by this release there is little point mentioning them!

Version 1.4.4, released: 06/Apr/2012

New Feature: Set a background image in full screen mode

You can now set the background image when in full screen mode.

New Feature: Achievements

Writing is a thankless task, 100 achievements will help you along and of course they can be switched off. To view your achievements just use the Achievements menu item from the project menu.

New Feature: Interactive tips

When Quoll Writer starts an interactive tip will be displayed at the bottom of the window, the tips can be turned off if desired and most of them are interactive in some way.

New Feature: Appears in Chapters now auto updates

The Appears in Chapters panel displayed for assets will now auto update and work on the actual text in the editors rather than the saved text.

New Feature: Note types can be managed

A long overdue feature! You can now add/edit/delete the note types, just right click on the Notes section and select Manage Types.

New Feature: Item types can be managed

A long overdue feature! You can now add/edit/delete the item types, just right click on the Items item in the Assets section and select Manage Item Types.

New Feature: Can unignore problems found by Problem Finder

A long overdue feature! You can now view and unignore problems found by the Problem Finder.

New Feature: New keyboard shortcuts

The following keyboard shortcuts have been added:

  • Ctrl+Shift+P to open the Problem finder.
  • Ctrl+E to open the Edit Text Properties popup.
  • Ctrl+R to open the Readability popup.

Minor changes

  • A number of minor cosmetic changes have made including changes to button spacing, converting some icons to buttons and spacing/font sizes for headers.
  • When a scene is deleted if it has associated Plot Outline Items then the user is asked if they wish to also remove them.
  • When a Plot Outline Item is viewed if there is an associated scene then a link is displayed for it.
  • Can no longer add Plot Outline Items or Scenes from the Chapters tree.
  • Edit Needed note type removed from list of normal note types.
  • The state of the Add the description to the Chapter checkbox (when you add Scenes/Plot Outline Items) is remembered across the session.
  • Global find now works everywhere not just when you a chapter is the current tab.
  • Global find will open next to the main window, or as much as is possible to do so.
  • The global find will search on highlighted text from a chapter.
  • Spellcheck will ignore numbers.
  • Spellcheck will allow words ending with s or ed if that word is in the thesaurus.
  • Global find will now work in warm-ups window.
  • Double clicking on the parent node in the Assets tree will add an item of that type, for example double click on Characters will add a new character.
  • If there are no synonyms for a word then "No synonyms found for: [word]" will be displayed instead of Find.
  • Undos/redos now work on the entire string being edited rather than on single character.
  • Bold/italic/underline handling has been reworked to be an order of magnitude more efficient.
  • The help button on the Problem Finder now goes to the online help.
  • A couple of minor enhancements to how the Problem Finder handles sentences and words.
  • Highlight color for the Problem Finder has been changed to red.
  • Problem Finder will start finding problems from the current caret.
  • The ordering of the problems found by the Problem Finder has been modified.
  • When an item is double clicked in the Appears in Chapters panel the associated text in the chapter is highlighted.
  • Character aliases are now added to the per-project dictionary.
  • A snippet count indicating the number of times a term has been found is now displayed for each chapter in the global find.
  • A snippet count indicating the number of times a reference to an asset has been found is now displayed for each chapter in the Appears in Chapters panel.
  • The Problem Finder will now take notice of modified text within the chapter rather than working on a snapshot of the text taken when the finder is opened.

Bug fixes

  • Edit needed notes now moving with their associated text.
  • Edit needed notes, when viewed display above or below their associated text.
  • American dictionary files now available and loading.
  • Removing an asset will remove the asset name and aliases from the per-project dictionary.
  • The Problem Finder now can be displayed even if the chapter is empty.
  • Clause rule for the Problem Finder now finds the right number of clauses.
  • Aliases are now saved for characters.
  • Fixed the snapshot time setting so that 24 hour actually means 24 hours.

Version 1.4.3, released: 15/Nov/2011

New Feature: Idea Board

An Idea Board has been added to allow you to record and catalogue your ideas. See the Idea Board overview for more details.

New Feature: Readability Indices

The following readability algorithms have been implemented within Quoll Writer to help determine the complexity of the text:

An example is shown below:

See the readability help page for full details.

New Feature: Find passive sentences in the Problem Finder

A new rule for finding passive sentences (use of passive voice) has been added to the Problem Finder. Note: due to the complexities of the English language and the rather fluid definition of passive voice only a subset of instances may be found via this rule.

New Feature: Added a clock to the full screen mode

Since the full screen mode hogs the available space and can block the task bar a clock has been added to the header.

New Feature: Word counts/timer in full screen mode

Just like for warm-ups you can now specify a time and/or word count in full screen mode to track your writing progress.

New Feature: Edit Needed notes

This is a type of note that has special features, you can select a section of the text and then use the special menu item (accessible via the chapter right click menu or the new object menu) to create the note. When you then view the note, the associated text will be selected in the chapter.

New Feature: Global find added, old inline find removed

The old, chapter only inline find was too restrictive and not useful for finding all references to a word or name. A new global find has been added to allow searching across (nearly) all of the text in your project. Note: the inline chapter find has been removed.

Minor changes

  • Modifications to the import/export process to include missing information such as the item type and research item website.
  • The startup splash image no longer shows on top of other windows.
  • When moving in and out of full screen mode the caret is kept visible.
  • Buttons have been given a little more space, this makes them easier to press and more visually appealing.
  • Added the Find icon to the chapter toolbars.
  • Slight redesign of the project menu to more logically group related items together.

Bug fixes

  • An annoying bug relating to the positioning (and subsequent movement) of scenes and plot outline items in chapters has been fixed.
  • Plot outline items are now added correctly to scenes.
  • User defined problem finder rules are now removed from all projects when specified.

Version 1.4.2, released: 30/May/2011

New Feature: Per-project dictionary and user dictionary management

Each project now has it's own dictionary which consists of the names of the Assets within the project. Also the users' personal dictionary can now be managed from the project options. Words can be added and removed. Shown below is the dictionary manager.

See the dictionary management help page for full details.

New Feature: Play a typewriter sound when a key is pressed

You can now have the sound of typewriter key being pressed played when you press a key. See the help page for full details.

New Feature: Display spelling suggestions even when spell check is off

If you right click on a word and it is not in the dictionary then spelling suggestions will now be displayed regardless of whether the spell check is on or off.

New Feature: Spell check language can be selected

It is now possible to select the language, and thus the dictionaries, used in the spell check, see the help page for full details.

New Feature: Specify the location of the toolbar

It is now possible to specify whether the toolbar is displayed above the chapters list or below the notes section. See the help page for full details.

New Feature: Appears in section added for assets

All assets now have an Appears in section (just like characters) that displays where the asset is mentioned in the chapters.

Changed Feature: User must type a word when confirming deletion of chapters/projects

The two stage, potentially confusing, deletion process for chapters and projects has been changed to require the user to type the word yes in a box as confirmation instead.

Changed Feature: Visual changes to the project options

The look of the project options has been changed to make it clearer and give better division between the sections. The options have also been split into tabs, a tab for Project specific options and a Chapter tab for chapter specific options.

Minor changes

  • More key bindings have been added to allow shortcuts for common actions such as creating assets, see the help page for full details.
  • A link to the release notes for the current release has been added to the About window.
  • A check has been implemented to ensure that the size of the Quoll Writer window never exceeds the size of the user's display.
  • A warning is now output if Quoll Writer is using a font not installed on a user's machine.
  • The EPUB export format now wraps each paragraph in a p tag. This is to get around issues with certain EPUB readers that do not display the markup correctly.
  • 's version of asset names are now added to the per project dictionary when the asset is added (and removed when the asset is removed).

Bug fixes

  • The inline find has been modified to jump back to the top of the text when no more matches are found in the text.

Version 1.4.1

New Feature: Full Screen Mode

The most requested feature for Quoll Writer is to have a full screen mode where you can write without distractions. Version 1.4.1 introduces a full screen mode as can be seen below.

Full screen mode can be accessed by pressing the F5 function key or via the Full Screen Mode icon on the Chapter toolbar.

Once in full screen mode moving the mouse to the top or bottom of the screen will display the header as shown below.

Use the Chapter list in the header to switch to a different chapter.

The following settings can be changed in full screen mode:

  • The size of the writing area, this is performed by either dragging the borders of the writing area or by dragging the Display Area Size box in the header.
  • How transparent the background area/border is, this is performed by either moving the mouse wheel up/down in the background area or by using the slider in the header.
  • Font, font size, text alignment, line spacing and color of the text and background area.

An example of changing some of the settings is shown below:

The settings will be saved when you exit full screen mode. Note: color changes only apply for full screen mode.

You can exit full screen mode at any time by pressing Escape or the F9 function key or by using the Full Screen Mode Exit button on the header.

Full screen mode is also available when writing a warm-up.

New Feature: Support for bold, italic and underline

Support has been added for applying the styles bold, italic and underline to the text in chapters. Note: the styles can only be applied when you have selected part of the text. Use keyboard shortcuts Ctrl+B, Ctrl+I and Ctrl+U for bold, italic and underline respectively. Menu options will also be displayed if you highlight some text and then right click in the chapter as shown below:

Bug Fixes

  • Linking objects when a new project has been created (but not saved) will no longer throw an error.
  • Fixed an issue where converting a warm-up to a project before the warm-ups viewer had been restarted resulted in an error being displayed (although the error would not prevent the project from being created).
  • Fixed an issue where you could not delete a chapter if a note was linked to it and had been added to the chapter.
  • Inserting scenes between outline items now works correctly.

Internal Changes (dull techie stuff)

  • Modified the panels to allow support for popups in any type of panel not just for chapters.
  • Modified the way that the position of popups is calculated.
  • Ensured that popups are linked to the parent panel rather than the project viewer (where possible).

Version 1.4

New Feature: Warm-ups

The Warm-ups feature is aimed at helping with the following common problems for writers:

  • Warming up before tackling your main story.
  • Combating writer's block.
  • Boredom, with over 300 prompts to choose from there will be something that takes your fancy.
  • Looking for something new. We've all suffered from the shiny new project syndrome where starting something new is much more fun than completing an existing project.
  • Rounding out your writing skills.

The brain, like other muscles in the body, needs warming up before it is at it's best. The warm-up selection window is shown below. When you start a new warm-up you can select a writing prompt and then free write for a fixed amount of time or until you reach a certain number of words.

All the warm-ups are stored in a separate Warm-ups project so you return to a previous warm-up and work on it further or convert it into a new project. The main warm-ups window is shown below. It is very similar to the normal project window.

New Feature: Problem Finder

We all make mistakes whilst writing, often we don't want to break our flow to check to see if we are using suspect phrases or repeating ourselves. Even during editing it can be easy to overlook some of the problems that have crept into the prose. The Problem Finder feature is aimed at helping to find these problems. It will look for the following types of problems:

  • The use of certain words, phrases or punctuation that tend to be frowned upon.
  • The use of adverbs to modify a speech verb, such as "he shouted effusively".
  • Overly long sentences.
  • Sentences with too many clauses.

An example is shown below:

And closer in:

It is important to realize however that these problems are only an issue in certain circumstances and you may not, for your particular writing style/preferences, consider them problems at all. They are there as a guide rather than for enforcement. Each of the individual problems found can be ignored and the various types of problem can be ignored if required. It is also possible to add your own rules for words/phrases you consider to be problems and you would like to avoid.

New Feature: Added Sparklines to the word count popup summary

Sparklines are basically mini charts and an excellent way for seeing at a glance how something is progressing. Two sparklines have been added to the popup, one to show the word count progress over the past 7 days for the current chapter and another for all chapters for the previous 30 days. This allows you to easily see whether the word count for the chapter/book is going up or down.

New Feature: Can select the chapter to display in the Chapter Word Counts chart

This feature allows you to see the word counts for selected chapters.

An example is shown below:

New Feature: Notification bar

A notification bar has been added to the main window and will be displayed when important messages need to be conveyed to the user, such as when a new version of Quoll Writer is available for installation. This feature also allows removal of the popup window that was displayed when an automatic snapshot of the Project was created.

An example is shown below:

New Features: New Export Formats

It is now possible to export your project as PDF, HTML or EPUB. Just use the Export Project option from the Project menu.

New Feature: New Tools menu

A new Tools menu has been added to the Chapter tool bar. Print Chapter and Edit Text Properties have been moved to that menu along with Find Problems option.

New Feature: Allow urls and links to other objects be used in all multiline text boxes

This feature allows the user to use website links and references to other objects such as Characters and Items in multiline text boxes, such as the description for a Character. The links are highlighted and can be clicked on to go to that page or object tab.

An example is shown below:

New Feature: Allow tab key to move between text fields

This feature allows the user to move from one text entry box to another using the tab key, even for multiline text boxes.

Changed Features

  • Modifications to DOCX exporter
    The DOCX project exporter has been modified to respect the font, font sizes, line spacing, text alignment and indentation for the project in the output .docx files.
  • Changes to text size
    The editor font sizing has been modified to match the screen resolution. In short, this means that the size you see on screen will be the same as what is printed.
  • Changes to text properties
    Setting the text properties will set them for all chapters in the project and the settings will become the default for the project.
  • Changes to line spacing
    The line spacing has been corrected so that it is accurate given the screen resolution and font size.
  • Improved A4 page count calculation so that it is more accurte.
  • Improved the look of the charts in the Word Count panel.
  • Number formatting tweak on the word count popup.
  • Changed the find to start finding from the current caret rather than the start of chapter.
  • Streamlined the startup handling so that Quoll Writer starts faster, especially for larger projects.
  • Can contact support/report a problem straight from Quoll Writer itself rather than via email.

Bug Fixes

  • Changing the Display value for the Total Word Counts chart now works.

Internal Changes (dull techie stuff)

  • The fonts/font sizes used has been standardized across all UI components.
  • Modifications to drop shadows
    The drop shadows on the left hand panel and popups have been made more rounded and consistent. The popup drop shadow has been made more prominent to ensure that it looks raised.
  • Dropped the primary key from the wordcount table.
  • Made all popups derive from a single implementation.
↑ Back to top